pomodoroprompt/shell.nix
Chris (wolcen) Thompson f908389c40 Add text entry history/editing/auto-complete
...and import utc directly
2024-11-19 10:59:14 -05:00

23 lines
670 B
Nix

# shell.nix
let
# We pin to a specific nixpkgs commit for reproducibility.
# Last updated: 2024-04-29. Check for new commits at https://status.nixos.org.
pkgs = import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/aebe249544837ce42588aa4b2e7972222ba12e8f.tar.gz") {};
in pkgs.mkShell {
packages = [
(pkgs.python3.withPackages (python-pkgs: with python-pkgs; [
# select Python packages here
playsound
pycairo
pytz
tzlocal
prompt-toolkit # for text entry history/auto complete
# For Qt:
# pyside6
# Using GTK:
pygobject3
]))
pkgs.wrapGAppsHook
pkgs.gobject-introspection
];
}