22 lines
610 B
Nix
22 lines
610 B
Nix
# shell.nix
|
|
let
|
|
# We pin to a specific nixpkgs commit for reproducibility.
|
|
# Last updated: 2024-04-29. Check for new commits at https://status.nixos.org.
|
|
pkgs = import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/aebe249544837ce42588aa4b2e7972222ba12e8f.tar.gz") {};
|
|
in pkgs.mkShell {
|
|
packages = [
|
|
(pkgs.python3.withPackages (python-pkgs: with python-pkgs; [
|
|
# select Python packages here
|
|
playsound
|
|
pycairo
|
|
pytz
|
|
tzlocal
|
|
# For Qt:
|
|
# pyside6
|
|
# Using GTK:
|
|
pygobject3
|
|
]))
|
|
pkgs.wrapGAppsHook
|
|
pkgs.gobject-introspection
|
|
];
|
|
}
|